Electrician Talk banner
1 - 9 of 9 Posts

·
Golden Controls
Joined
·
616 Posts
Discussion Starter · #1 ·
Does anyone have experience with the Rotork Process Actuators? I have an SM 1630 that I cannot get any feedback from. http://rotorkprocesscontrols.com/pdf/im/im-0402-sm-1500,1600.pdf

any info would be great.

I have the wiring made as shown but I recieve no feedback from the unit. Are the surface mount leds suppose to light when the unit has power or only when in motion or a certain postion?
 

·
Proud Navy Veteran
Joined
·
1,429 Posts
Does your unit have the built in amplifier? If so you will need a signal generator capable of 0-20mA DC signal then follow the initial installation instructions. The is also a pretty good troubleshooting chart in that paperwork that seems to describe your scenerio.

It looks as they are supposed to light when moving in certain directions. Do you have the optional feedback transmitter (4-20mA).
 

·
Golden Controls
Joined
·
616 Posts
Discussion Starter · #3 ·
Does your unit have the built in amplifier? If so you will need a signal generator capable of 0-20mA DC signal then follow the initial installation instructions. The is also a pretty good troubleshooting chart in that paperwork that seems to describe your scenerio.

It looks as they are supposed to light when moving in certain directions. Do you have the optional feedback transmitter (4-20mA).
we have the transmitter but do not have the amplifier
 

·
Registered
Joined
·
49 Posts
Rotork Suggestion

We had a rotork with a similar problem. It turned out the installer had reversed the 4-20ma feedback signal leads. Once we swapped them, we were able to see the readout indicating the percentage the valve was open in our Scada system.
 

·
Registered
Joined
·
931 Posts
are you saying you installed it in 2008 and now it isnt working right? I thought the other poster had good solution, but if it has stopped working that is another matter.. Info up front is always better :laughing:
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top