Electrician Talk banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Dear Senior.....

Today i found a little bright light from indicator lamp , which the indicator lamp are not running , when i used multimeter to test the voltage is about 20V flow on the lamp , is that call voltage leaking ? how to i ensure for this troubleshoot ? and repair ?? :eek:

1) change the cable ?
2) change the relay ?

Thanks for advise ..
 

·
Electrical Contractor
Joined
·
9,327 Posts
Dear Senior.....

Today i found a little bright light from indicator lamp , which the indicator lamp are not running , when i used multimeter to test the voltage is about 20V flow on the lamp , is that call voltage leaking ? how to i ensure for this troubleshoot ? and repair ?? :eek:

1) change the cable ?
2) change the relay ?

Thanks for advise ..
Loose neutral?
 

·
Registered
Joined
·
4,154 Posts
Check for phantom/ghost voltage first.
Check the power source, what feeds this equipment?
You could be feeding through a load.

need to check the wiring.
 

·
Registered
Joined
·
1,767 Posts
Check for phantom/ghost voltage first.
Check the power source, what feeds this equipment?
You could be feeding through a load.

need to check the wiring.
also use an analog meter or inductive tester.
more information would be helpful in determining what is happening.
induced voltages can cause some problems but more than a few headaches.

check wiring to see if you have loose neutrals. close proximity to large motors,
if using shielded power cables make sure the shield/drain wire is bonded at one end only(preferably at supply end) and not at both ends
 
1 - 6 of 6 Posts
Top